postage/shell.nix
2024-07-14 17:09:46 +02:00

15 lines
256 B
Nix

{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell rec {
buildInputs = with pkgs; [
linux.dev
gcc
wireshark
gnumake
];
shellHook = ''
export PATH="$PATH:$PWD/opt/bin"
export CC="i686-elf-gcc"
'';
}